ITよろづや

ITから生活の参考になる情報を備忘録代わりに残していきます

Ansible Dell EMC OMSDK library is required for this moduleエラー

Ansible Dell EMC OMSDK library is required for this moduleエラーに関する情報です。

 

情報元はこちら

Dell EMC OMSDK library is required for this module · Issue #112 · dell/dellemc-openmanage-ansible-modules · GitHub

 

質問内容の抜粋です。※機械翻訳

 

===

OpenManageライブラリをインストールしましたが、AnsibleでPython3とPython2の両方のインタープリターを使用すると、「このモジュールにはDellEMCOMSDKライブラリが必要です」というメッセージが表示されます。readmeに記載されているもの以外に追加のインストールが必要ですか?

 

Pythonバージョン
Python 3.7.6
注:Python2.7でも試してみました-同じエラーです。

 

Ansibleバージョン
ansible 2.9.6
  config file = /opt/dell/Dell Ansible Testing/code/ansible.cfg
  configured module search path = ['/home/grant/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python3.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 3.7.6 (default, Jan 30 2020, 10:29:04) [GCC 9.2.1 20190827 (Red Hat 9.2.1-1)]

===

 

 

続いて、解決したという内容です。

 

OMSDKモジュールを手動でインストールすることでこのエラーを修正しました。開発者にとって-これは設計によるものですか、それとも何かのマークを見逃しましたか?もしそうなら、私はプルリクエストを介して更新された指示を提供することができます。

 

修正するには:

 

git clone https://github.com/dell/omsdk.git
cd omsdk
pip3 install wheel
pip3 install -r requirements-python3x.txt
sh build.sh 1.2 423#注:数値は現在のバージョンに基づいて変更される場合があります。現在のOMSDKリポジトリを参照してください。
cd dist
pip install omsdk-1.2.423-py2.py3-none-any.whl


その後、エラーはクリアされました。

===

 

バッファロー WiFi 無線LAN ルーター WSR-1166DHPL2/N 11ac ac1200 866 300Mbps IPv6対応 デュアルバンド 3LDK 2階建向け 簡易パッケージ テレワーク 日本メーカー 【 iPhone 13 / 12 / iPhone SE(第二世代) / Nintendo Switch メーカー動作確認済み】